最新消息:阿啰哈,本人90后,目前单身,欢迎妹子们来撩!.(。→‿←。) 微信:frank01991

综合练习实验

Cisco 林志斌 1007浏览


通过上面Topology的练习:

STP(pvst or rapid-pvst)、VTP、DTP、VLAN、EtherChannel(Cisco PAcP、IEEE 802.3ad LACP)、PortSecurity、VLAN间路由等NA交换命令。
MS1_1及MS_2是所有VLAN的primary root and second root,还是整个VTP domain(domain name cisco)中的server,其余都是client。在MS_1或MS_2 core switch中添加vlan 2、vlan 3、vlan 4,整个网络的交换机都学习到了所有新增的VLAN。记住,Cisco交换机的端口默认为switchport mode dynamic auto模式,这样可以很方便我们设置端口的trunk模式。但是,为了使网络更健康,建议不使用DTP。根据需要,适当设置portsecurity特性(该实验在PT5.3上模拟的,后面给core switch上的server设置portsecurity时,程序老是崩溃!)。两台server都放置在vlan 4中,PC0被放置在vlan 2中,PC1在vlan 3。通过core switch实现vlan间的路由。建议更改native vlan,如果更改了native vlan,关闭vlan 1。EtherChannel load balancing……
下面只剪切了MS_1、SwA和S1的简单配置。该实验还可以进一步拓展练习 ……

MS_1#sh run
Building configuration...

Current configuration : 2924 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname MS_1
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
aaa new-model
!
username kashu privilege 15 password 7 082A4D5D010C
!
ip ssh version 2
ip ssh authentication-retries 2
ip ssh time-out 30
no ip domain-lookup
ip domain-name kashu.cisco.com
!
spanning-tree vlan 1-5 priority 4096
!
interface FastEthernet0/1
 description connection to SwA switch
 switchport trunk native vlan 5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/2
 description connection to SwB switch
 switchport trunk native vlan 5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/3
 description connection to MS_2 core switch
 channel-group 1 mode desirable
 switchport trunk native vlan 5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 duplex full
 speed 100
!
interface FastEthernet0/4
 description connection to MS_2 core switch
 channel-group 1 mode desirable
 switchport trunk native vlan 5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 duplex full
 speed 100
!
interface FastEthernet0/5
 description connection to WWW:220.248.192.1
 switchport access vlan 4
 switchport mode access
 spanning-tree portfast
!
[output cut]
!
interface Port-channel 1
 description MS_1 f0/3-4 - MS_2 f0/3-4
 switchport trunk native vlan 5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description ForPC0
 ip address 192.168.2.254 255.255.255.0
!
interface Vlan3
 description ForPC1
 ip address 192.168.3.254 255.255.255.0
!
interface Vlan4
 description ForServer
 ip address 220.248.192.254 255.255.255.0
!
interface Vlan5
 description For Management
 ip address 192.168.5.254 255.255.255.0
!
ip classless
!
no cdp run
!
banner motd ^CThis is MS_1 core switch^C
!
line con 0
 exec-timeout 0 0
 password 7 0822455D0A16
 logging synchronous
 login
line vty 0 4
 access-class 1 in
 exec-timeout 0 30
 password 7 0822455D0A16
 logging synchronous
 login
 transport input ssh
!
end

SwA#sh run
Building configuration...

Current configuration : 2383 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SwA
!
no ip domain-lookup
!
interface FastEthernet0/1
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/2
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/3
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/4
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/5
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/6
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/7
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/8
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/9
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/10
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/11
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/12
 switchport trunk native vlan 5
 switchport mode trunk
 switchport nonegotiate
!
[output cut]
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 no ip address
!
interface Vlan3
 no ip address
!
interface Vlan4
 no ip address
!
interface Vlan5
 description For Management
 ip address 192.168.5.3 255.255.255.0
!
ip default-gateway 192.168.5.1
!
no cdp run
!
access-list 1 permit 192.168.5.0 0.0.0.255
line con 0
 password cisco
 logging synchronous
 login
 exec-timeout 0 0
!
line vty 0 4
 access-class 1 in
 exec-timeout 0 30
 password cisco
 logging synchronous
 login
line vty 5 15
 login
!
end

S1#sh run
Building configuration...

Current configuration : 1925 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
no ip domain-lookup
!
interface FastEthernet0/1
 description connection to SwA switch
 switchport trunk native vlan 5
 switchport trunk allowed vlan 2,5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/2
 description connection to SwB switch
 switchport trunk native vlan 5
 switchport trunk allowed vlan 2,5
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/3
 description connection to PC0
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
[output cut]
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description For PC0
 no ip address
!
interface Vlan3
 no ip address
!
interface Vlan4
 no ip address
!
interface Vlan5
 description For Management
 ip address 192.168.5.5 255.255.255.0
!
interface Vlan56
 no ip address
!
ip default-gateway 192.168.5.1
!
no cdp run
!
banner motd ^CThis is S1^C
!
access-list 1 permit 192.168.5.0 0.0.0.255
line con 0
 password 7 0822455D0A16
 logging synchronous
 login
 exec-timeout 0 0
!
line vty 0 4
 access-class 1 in
 exec-timeout 0 30
 password 7 0822455D0A16
 logging synchronous
 login
line vty 5 15
 login
!
end

Verifying:
MS_1#ping 220.248.192.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 220.248.192.1, timeout is 2 seconds:
!!!!!(ping WWW Server,Success)
Success rate is 100 percent (5/5), round-trip min/avg/max = 31/50/95 ms

MS_1#ping 220.248.192.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 220.248.192.2, timeout is 2 seconds:
!!!!!(ping FTP Server,Success)
Success rate is 100 percent (5/5), round-trip min/avg/max = 33/94/156 ms

MS_1#ping 192.168.5.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.3, timeout is 2 seconds:
!!!!!(ping SwA switch,Success)
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/47/62 ms

MS_1#ping 192.168.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.5, timeout is 2 seconds:
!!!!!(ping S1 switch,Success)
Success rate is 100 percent (5/5), round-trip min/avg/max = 17/95/205 ms

MS_1#ping 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!(ping PC0,Success)
Success rate is 100 percent (5/5), round-trip min/avg/max = 47/131/203 ms

转载请注明:林志斌 » 综合练习实验

发表评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址