最新消息:阿啰哈,本人90后,目前单身,欢迎妹子们来撩!.(。→‿←。) 微信:frank01991

HP交换机的简单配置

HP 林志斌 1037浏览
0、设置终端显示界面大小:
Sw2610# terminal length 90 width 90

1、启用、禁用交换机接口:
Sw2610(config)# interface 1 
Sw2610(eth-1)# disable
Sw2610(eth-1)# enable 

2、相看接口相关信息:
sh int br
sh int co
sh int po
sh int 1
sh int

3、创建vlan 10,设置1-2接口加入到vlan 10中(即为access接口),并且vlan 10的流量允许从23-24接口通过(即为trunk接口)
Sw2510(config)# vlan 10
Sw2510(vlan-10)# untagged 1-2
Sw2510(vlan-10)# tagged 23-24
Sw2510(vlan-10)# sh run
vlan 10
   name "VLAN10"
   untagged 1-2
   tagged 23-24
   exit

4、把1接口从vlan 10删除,并关联到vlan 20里面去(直接把1接口关联到vlan 20即可,1接口就自动不和vlan 10关联了):
Sw2510(config)# vlan 20 untagged 1
Sw2510(config)# sh run
vlan 10 
   name "VLAN10" 
   untagged 2 
   tagged 23-24
   exit 
vlan 20 
   name "VLAN20" 
   untagged 1
   exit 

5、把之前的trunk 23接口从vlan 10中删除(即实现vlan 10的流量不允许从trunk 23接口通过)
Sw2510(config)# no vlan 10 tagged 23

Sw2510(config)# sh run
vlan 10
   name "VLAN10"
   untagged 2
   tagged 24
   exit

6、给vlan 10配置IP地址:
方式1:Sw2610(config)# vlan 10
Sw2610(vlan-10)# ip address 1.1.1.111 255.0.0.0
方式2:Sw2610(config)# vlan 10 ip address 1.1.1.111 255.0.0.0

7、启用web管理功能:
Sw2510(config)# web-management
注意先确定PC能与交换机的连通性,本地电脑需要安装java才能看到交换机的web界面内容(地址栏输入http://ip)

8、密码恢复与恢复设备出厂设置:
1)点击交换机前面板的clear按钮1秒后将删除交换的密码和用户名。
2)可以使用面板上的reset按钮恢复设备的出厂值:
同时按住reset及clear按钮,大约5秒钟后放开reset按钮,继续按住clear按钮,等板上自检(selftest)的,放开按钮。

9、通过CDP协议查看直接设备信息:
Sw2510# sh cdp nei de
 CDP neighbors information
  Port : 24  
  Device ID : 2c 76 8a 6f c2 00                                             
  Address Type : UNKNOWN     
  Address      : Unsupported format                                          
  Platform     : ProCurve J9088A Switch 2610-48, revision R.11.70, ROM R....
  Capability   : Switch                                                     
  Device Port  : 24                                                         
  Version      : ProCurve J9088A Switch 2610-48, revision R.11.70, ROM R....

10、配置LLDP查看直接设备信息:
Sw2610(config)# lldp config 24 ipAddrEnable 1.1.1.111(设置本地交换机使用的管理IP地址)
Sw2610(config)# sh lldp info remote-device 24

 LLDP Remote Device Information Detail
  Local Port   : 24(本地交换机的接口号是24,与对端交换机直连着)
  ChassisType  : mac-address 
  ChassisId    : 84 34 97 34 e5 40(对端交换机24接口的MAC地址)        
  PortType     : local
  PortId       : 24(对端交换的24端口与本交换机直连)                       
  SysName      : Sw2510(对端交换机的主机名)                        
  System Descr : ProCurve J9019B Switch 2510B-24, revision Q.11.17, ROM Q....
  PortDescr    : 24(接口的描述信息)

  System Capabilities Supported  : bridge(对端是个交换机类型)
  System Capabilities Enabled    : bridge

  Remote Management Address
     Type    : ipv4
     Address : 1.1.1.112(对端交换机的管理IP地址)

11、查看系统信息:
Sw2510(config)# sh system-information 
 Status and Counters - General System Information
  System Name        : Sw2510                                          
  System Contact     :                                                 
  System Location    :                                                 

  MAC Age Time (sec) : 300    

  Time Zone          : 0    
  Daylight Time Rule : None                      

  Software revision  : Q.11.17          Base MAC Addr      : 843497-34e540
  ROM Version        : Q.10.02          Serial Number      : CN247FW18C  

  Up Time            : 45 mins          Memory   - Total   : 47,799,840  
  CPU Util (%)       : 2                           Free    : 41,397,424  

  IP Mgmt  - Pkts Rx : 242              Packet   - Total   : 3022        
             Pkts Tx : 13               Buffers    Free    : 2959        
                                                   Lowest  : 2956        
                                                   Missed  : 0 

12、启用ssh登陆:
Sw2610(config)# crypto key generate ssh rsa bits 1024
Sw2610(config)# ip ssh

13、关闭telnet登陆:
Sw2610(config)# no telnet-server

14、设置端口安全(类似cisco中的stick,最多允许1个MAC,超过1个MAC时接口会自动shutdown):
Sw2610(config)# port-security 10 address-limit 1 learn-mode static action send-disable
Sw2610(config)# port-security 10 address-limit 1 learn-mode static action send-alarm(发出告警信息)

15、端口聚合:
Sw2610(config)# trunk 23-24 trk1 trunk
Sw2610(config)# sh trunks

 Load Balancing

  Port | Name                             Type      | Group Type 
  ---- + -------------------------------- --------- + ----- -----
  23   |                                  10/100TX  | Trk1  Trunk
  24   |                                  10/100TX  | Trk1  Trunk

16、启用MSTP生成树协议(生成树默认是关闭的,需手工启用):
Sw2610(config)# spanning-tree
Sw2610(config)# sh span
 Multiple Spanning Tree (MST) Information

  STP Enabled   : Yes
  Force Version : MSTP-operation
  IST Mapped VLANs : 1-4094
  Switch MAC Address : 2c768a-6fc200
  Switch Priority    : 32768
  Max Age  : 20
  Max Hops : 20
  Forward Delay : 15

  Topology Change Count  : 0           
  Time Since Last Change : 2 hours     

  CST Root MAC Address : 2c768a-6fc200
  CST Root Priority    : 32768       
  CST Root Path Cost   : 0           
  CST Root Port        : This switch is root

  IST Regional Root MAC Address : 2c768a-6fc200
  IST Regional Root Priority    : 32768       
  IST Regional Root Path Cost   : 0           
  IST Remaining Hops            : 20          

  Root Guard Ports : 
  TCN Guard Ports  : 
  Protected Ports :                                                          
  Filtered Ports :                                                          
                  |           Prio             | Designated    Hello         
  Port  Type      | Cost      rity  State      | Bridge        Time  PtP Edge
  ----- --------- + --------- ----- ---------- + ------------- ----- --- ----
  1     10/100TX  | 200000    128   Forwarding | 2c768a-6fc200 2     Yes Yes 
  ……
  50    100/1000T | Auto      128   Disabled   |
  51              | Auto      128   Disabled   |
  52              | Auto      128   Disabled   |
  Trk1            | Auto      64    Disabled   |
 
17、启用路由功能:
Sw2610(config)# ip routing 

18、添加静态路由、默认路由:
Sw2610(config)# ip route 1.1.1.0 255.255.255.0 2.2.2.2
Sw2610(config)# ip route 0.0.0.0 0.0.0.0 3.3.3.3

19、设置操作员(普通用户,登陆到用户模式)和管理员(直接登陆到特权配置模式)的用户名和密码:
Sw2610(config)# password all 
New password for Operator: *****
Please retype new password for Operator: *****
New password for Manager: *****
Please retype new password for Manager: *****

20、配置使用SNTP(简单网络时间协议)同步交换机时间:
Sw2610(config)# clock  timezone gmt +8(设置时区为东8区)
Sw2610(config)# sntp server 1.1.1.1 7(7为SNTP版本号)

21、SNMP的简单配置:

HP E5406

snmp-server community "amtium" unrestricted
snmp-server host 172.16.14.254 community "amtium" trap-level all
snmp-server response-source 172.16.14.5
snmp-server trap-source 172.16.14.5

snmp-server community "public" operator restricted
snmp-server community "private" Unrestricted
snmp-server host 10.0.3.254 public all
snmp-server enable traps link-change ethernet 25-26
en
conf t
snmp-server enable
snmp-server community "amtium" Operator Unrestricted 
snmp-server host 172.16.14.254 "amtium" All
ex
wr me
ex
ex
y
conf t
snmp-server enable
snmp-server host 172.16.14.254 community amtium trap-level all
snmp-server community "amtium" Operator Unrestricted 
ex
wr me

ex
ex
y
22、配置镜像接口:
ProCurve Switch 2610-48(config)# mirror-port 1(接口1为流量分析接口)
ProCurve Switch 2610-48(config)# interface 24 monitor(接口24为被镜像接口,即源端口)
ProCurve Switch 2610-48(config)# sh monitor (显示镜像设置)
 Network Monitoring Port
  Mirror Port: 1
  Monitoring sources
  ------------------
  24                
 

23、保存配置文件:
Sw2610# write memory 
24、备份配置文件:
Sw2610# copy startup-config tftp 1.1.1.1 sw2610.cfg
Sw2610# copy running-config tftp 1.1.1.1 sw2610.txt


25、查看启用配置文件内容:
ProCurve Switch 2610-48# sh conf


26、备份交换机OS:
ProCurve Switch 2610-48# sh flash                    
Image           Size(Bytes)   Date   Version
-----           ----------  -------- -------
Primary Image   : 3934928   03/16/11 R.11.70 
Secondary Image : 3934928   03/16/11 R.11.70 
Boot Rom Version: R.10.06
Current Boot    : Primary

ProCurve Switch 2610-48# copy flash tftp 1.1.1.1 HP2610_OS.bin


27、HP交换机的Menu(菜单)模式
ProCurve Switch 2610-48# menu (方便新手对交换机的操作)

转载请注明:林志斌 » HP交换机的简单配置

发表评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址